Question about animations :/

  • Lunar Engine v0.2.6 is out now! Download and check it out here. The map editor is also now fixed!

Raklen

Member
Member
Jan 27, 2014
15
0
0
Gold
0
#1
Yeah, finally i added visual spells (love it), the simply and easy way with mirage 3.0.3 is riping it from elysium konfuze, searching 'spellanim', 'spellnum', max_spell_anim', no more than copy paste you will get your visible spells.

But i have a 'problem', i don't know how to preview the animations in the spell editor, i can see 1 frame only, i have the timer with the function too, i have the same with the sprite preview in character creation, i add two screenshoots and a little information about my forms.

spelleditor screen:

Spell Editor Form

The names of the things are:

scroll spell: scrlAnimSpell
scroll time: scrlSpellTime
scroll cycle: scrlSpellDone
picture: picSpell
and the timer is timer1

That's all i guess.

EDIT: Fixed the animation problems, was a problem with the timers and variables, the only thing left is that spells casted didn't show all the animation, it's randomly the frames that the spell show, also if i cast on a player the spell animation it's showed in a map corner, hope for some idea ^^
 

William

Veteran
Veteran
Member
May 29, 2006
2,228
0
0
www.key2heaven.net
Gold
0
#2
Sounds like you have a issue with some variables. Look at the different rec's in your bltspell sub (rec.top,...), they determine what picture will show. When you cast on a player you need to find the code for where it looks for the X and Y for the player, and you need to tweak that code to fit what you need. Because right now it sounds like it doesn't really get the correct information out of that.